Jayco RV Owners Forum

Thread Tools Display Modes
Old 01-04-2015, 08:04 PM   #11
Senior Member
Join Date: Dec 2014
Location: Lancaster CA
Posts: 107
Originally Posted by Mustang65 View Post
...You still need to isolate the cause of the blown fuses, before it plays hell on your camping trips.

Just my thoughts,

Because it has not happened again since the day of delivery I'm wondering if maybe the individual items, the tongue jack and the slide out, didn't just need to be exercised and loosened up. Broke in, if you will. I'll keep an eye on the things you mentioned though, just in case. Thanks

Russ661 is offline   Reply With Quote
Old 01-06-2015, 08:09 AM   #12
Senior Member
exjay1's Avatar
Join Date: Feb 2012
Location: Myrtle Beach, SC
Posts: 1,259
Idd stick with the blade fuse set up and keep searching for the cause if it blowing if continues. Seems going to the CB is just a convient way of band-aiding the issue.

*Currently trailer-less but shopping
07' GMC Envoy w/ P2 controller (current TV)
88' Chevy K5 Blazer (soon-to-be TV)
74' VW Superbeetle (1303)

exjay1 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:29 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.