Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-19-2012, 10:32 AM   #11
Junior Member
Join Date: May 2011
Location: Long Island, NY
Posts: 25
Mine just went off also at 5am today. Looked at the date and says it expired a few months ago. Need to pick one up this week.

cpa0912 is offline   Reply With Quote
Old 06-19-2012, 02:42 PM   #12
Junior Member
Join Date: May 2012
Location: Maine
Posts: 13
I just shipped mine back to MDI Industries. I'll let you all know the out-come. I did place our home CO detector in the trailer since it has been home and as far as I know neither the camper alarm or the home alarm has sounded. I've run the furnace a few times and given it time to build....I'm confused...it only seemed to alarm when we are in the **** thing

Jtrober is offline   Reply With Quote
Old 06-30-2012, 10:45 AM   #13
Join Date: Jan 2012
Posts: 56
Check for Methane smell it will also trip the LP detector.. Mine doing the same thing Wife and kids at the trailer for weekend it is doing it again. I will look at it next week Wife said there is a slight Methane odor under the sink. 2012 330 RLTS

rheyco is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:27 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.