Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-11-2013, 12:07 PM   #1
Junior Member
Join Date: Jun 2013
Location: Watertown, MA
Posts: 12
Wink New to the forum, somewhat seasoned camper

Happy owner of a used 2003 Jayco Qwest 8U. Picked it up last summer and have had a few solo outing as well as family outings with our son's family, grand kids make it so much more fun.

I'm having trouble attempting to find/join a group. I'm in search of advice with couple of issues.

Issue #1: when one of the beds is in the stowed position it drops below the center roller and is difficult to lift up and out over the roller. I've carefully examine the mechanics and was unable to detect any way to adjust the bed position/elevation.

Issue #2: the right tail/brake light is doesn't exactly function correctly. It behaves like a shorted bulb but I have done the bulb swap with the left and nothing changed. The tail light and brake light are not as bright as the left side.

If anyone can direct me to a forum for my model and/or problem or just provide solution info it would be greatly appreciated.
Oldgreystallion is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.