Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-11-2014, 07:59 PM   #1
Junior Member
Join Date: Apr 2014
Location: Chino Valley
Posts: 9
First nights out

We traveled about 50 miles up the road for 2 nights. Went great. From tent camping and truck topper camping to this what a nice trip. We could not get water heater to work. We tried the Lp side of it, no work, I think Its something I did or did not do.
Woke Sunday morning a bit of snow blowing, wind went crazy for most of trip. To be inside during the spring winds here was sure nice, walks were cool and sunny.
Has anyone left black water and gray water in tanks till the next weekend ?

bkcasa161 is offline   Reply With Quote
Old 05-11-2014, 08:03 PM   #2
Senior Member
Join Date: Jan 2014
Location: Aurora CO
Posts: 2,336
Yes.... Did you throw 2 deodorizer tabs in?

So long as the black side has sufficient liquid, it will be fine

Jim & Kim from Colorado

2014 Eagle 30.5 RLS
2015 Dodge 3500HD SRW 6.7L
Click on my profile for Mods and notes
Jmooney is offline   Reply With Quote
Old 05-11-2014, 09:51 PM   #3
Senior Member
Jagiven's Avatar
Join Date: May 2012
Location: Minnesota
Posts: 3,182
Most people have issues flipping on the furnace the first time as you think you are going to break the little lever.

As for the black tanks. No big deal, just add the deoderizers
Jagiven is offline   Reply With Quote

2010 octane 161

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.