Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-29-2012, 07:39 PM   #1
Senior Member
Join Date: Mar 2012
Location: Livermore,California
Posts: 375
Loose hubs resolved..dexter axle responds

After having our wheel bearings replaced on our swift 184, [recall issue] I could still wiggle the wheels slightly after jacking up the tt. After several opinions I finally e mailed Dexter Axel and today received their response. A small amount of movement is ok,over tightening could destroy the new bearings. Hopefully, this will be the end of our wheel bearing saga. Thanks to all at this site for your info about this issue, and thanks for listening to me rant for the last couple months over trying to get this issue resolved. Maybe now we can really begin to enjoy our tt , without always being concerned about the wheel bearings. Again , thanks to all.........Happy camping!

bayleightucker is offline   Reply With Quote
Old 09-11-2012, 06:57 PM   #2
Senior Member
muelldawg's Avatar
Join Date: Aug 2010
Location: Phoenix, AZ
Posts: 382
We also had a loose wheel issue. And did not know it until we had bearings packed and teck showed us the VERY VERY BALD tire. It seems it was the threads on axle which we had cleaned up. We were lucky it did not require a new axle.

Just today, we received a call from our RV Dealer and they advised of an AXLE recall. I wonder if this is related to our problem a few months ago.
Richard & Marilyn
2010 Ford F150, V8, 5.4 liter
2010 Jay Feather Sport 165
muelldawg is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:41 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.