Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-05-2011, 10:24 AM   #1
Junior Member
Join Date: Apr 2011
Location: Iowa
Posts: 12
Skylark problem with AM radio

We purchased a new Skylark several months ago. We noticed that the AM radio did not work and the dealer could not resolve the issue.

They arranged to send us a new radio and I connected the wires to the one they sent and it worked the same.

We recently traveled to Colorado and stopped at a Jayco dealer and asked them to look at the unit. They stated:

"There is no AM input to the unit. This is per design. Radio does not have an AM port."

Showing them the brochure and the window sticker which both clearly indicate that it has an AM radio seemed to not deter them. They then charged me $129.00 in labor for their efforts.

Does anyone else have the Skylark that has a working AM radio?

We have a Jensen AWM970 radio.

Thanks for any input.

awindj is offline   Reply With Quote
Old 07-05-2011, 11:05 AM   #2
Site Team
Denise's Avatar
Join Date: Jul 2009
Location: Mostly the US
Posts: 9,987
We have the same radio. The AM does work on ours. Somehow, something doesn't sound right if it doesn't have the input or AM port. Sounds like someone screwed up at the factory? You bought as advertised, so is a warranty issue; they shouldn't have charged you. You might want to consider calling Jayco direct and let them know about what's going on. If you can't get to a dealer, request a referral to a local shop to have it fixed. Let us know how it goes

Denise, DH, grandkids, and two rescue pups
-2016 Jay Flight 29QBS Elite
-2016 Ford F-250 XLT 4x2, 6.2L EFI V8, 4.30 Elec Lock, Heavy duty Alt

CLICK HERE to save 30% $$ or more off your next Jayco RV
Denise is offline   Reply With Quote
Old 07-05-2011, 11:16 AM   #3
Senior Member
OurJayco's Avatar
Join Date: Nov 2009
Location: East Bethel, Minnesota
Posts: 656
"Port" or "Input" for AM is done through the antenna.
If only the AM is not working and this is the second unit with the same problem, I would assume the antenna is not properly ground or not grounded at all.
How is the reception for FM stations on this radio compared to those that you know are good in your truck, car or home?

If you can put the radio on an AM station that you know, put it on that station and have some go outside and grab the antenna. You should get some different noise or better reception.
Let us know what you find out. You may even want to go to a local car parts store and buy a real cheap antenna and plug it in the radio yourself and see what happens. If you do this, hold the base or the antenna.

Daryl and Sandy
2013 Eagle 314BDS
2012 Ford F150 Platinum, 4 x 4 Crew Cab with Ecoboost
Equal-i-zer Hitch
OurJayco is offline   Reply With Quote
Old 07-06-2011, 08:23 PM   #4
Junior Member
Join Date: Apr 2011
Location: Iowa
Posts: 12
Radio is working on strong stations now.

I called the dealer that I purchased the trailer from and they agreed there should be no warranty charge for the work done on the radio. I have provided them the documentation of the charges and they will contact Jayco. They were pretty sure I will get reimbursed but warned it would probably take a while.

I tried grabbing the antenna with the radio on AM, didn't notice any difference. When I got back on the ground, I could tune in a couple of strong local stations.

The antenna seemed to be very loose like it was only the calking that was holding it on.

I will call a local Jayco dealer to see if they can work on it. I do have a number of other issues that have come up.

Thanks for the suggestions.
awindj is offline   Reply With Quote
Old 11-14-2011, 07:56 AM   #5
Junior Member
Join Date: Apr 2011
Location: Iowa
Posts: 12
Jayco can't solve AM radio problem

This is a follow up on our AM radio that doesn't work. Des Moines RV has done a good job of handling a number of warranty issues this summer. The only thing left is the AM radio.

They tried several things and have been working with Jayco to figure out. The last thing they were going to try was to replace the LED lights with incandescent lights. We decided to keep the LED's and give up on the radio.

We also tried to call Jayco and ask for their help with the bill from K & C RV Centers in Longmont, Colorado who charged us $129.00 to tell us we really didn't have an AM radio.

Jayco pretty much said that is an issue with the dealer and not them.

I guess all that I learned from this was that you better beware when you don't buy locally.
awindj is offline   Reply With Quote
Old 11-14-2011, 08:31 AM   #6
Senior Member
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 2,526
We have the AWM970 as well tho not in a Skylark. We had a different problem with ours that was solved with a replacement radio. Your problem sounds like it might be an antenna issue.
As "OurJayco" pointed out there is no "port", there is an antenna input however. I seem to recall a post where someone was having interferrence problems due to the LED bulbs. "LadyFitz" was that you??

Thanks for naming the unhelpful dealer in CO. My take is they either doesn't know what they are doing or they were lying to you. Either way I'd suggest a letter to Jayco is in order to let them know what poor service you got - include a copy of the $129 bill you paid for "nothing".

I've had minimal problems (so far) and have worked directly with Jayco to resolve the one big issue (they sent the replacement radio directly to me and sent me a check to cover shipping the old one back). I have yet to take our trailer to a dealer for warranty work and I'm hoping that I won't have to.

Please update us as this moves forward. Hoping for a good outcome!


2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.