Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-19-2014, 08:57 PM   #1
Senior Member
Join Date: Jan 2014
Location: Bremerton
Posts: 285
Question 26BHS oven acting up

OK folks,
my oven has been unreliable since I got it. (too late now for warranty).

Then, It would light, come to temp, but would not relight to maintain temp.

NOW, the Pilot light would "sputter" on/off and not light. when it did light, flame would come out of both the pilot nozzle, and the threaded connection to the gas line.

I took it all apart, wiped off the carbon, cleaned the gas line and threads. After reassembly, pilot and main burner lit fine. set the oven to 350, but when I check a little while later, the oven temp was near 400, and the pilot was sputtering again.

Thoughts? Solutions?

tjpolsin is offline   Reply With Quote
Old 08-21-2014, 09:07 AM   #2
Senior Member
Join Date: Jan 2014
Location: Bremerton
Posts: 285
Several diligent searches on the internet AND this forum, indicated that I was not alone in my struggles.

I called Atwood to see if they had a solution and told me to start by checking the gas pressure downstream of the propane regulator. Too high or too low will cause the pilot to flame out when the main burner cycles.

I intend to take off my regulator and have it shop tested (vice dragging the whole trailer to a RV shop).

more to follow.

tjpolsin is offline   Reply With Quote
Old 08-24-2014, 04:38 PM   #3
Senior Member
Join Date: Jan 2014
Location: Bremerton
Posts: 285

I found a you-tube video about how to build and use a manometer to test LP gas pressure in an RV.

I connected the manometer to one of the stove burners and initially read 10"WC, but it quickly dropped to 9"WC after I lit the second burner, then even farther as I started the water heater.

I then connected the manometer upstream of the atwood regulator to test the TT main regulator, it read 10.5"WC, that quickly dropped after starting the furnace and water heater.

I found an adjustment procedure for the TT regulator and raised the static pressure to just above 11"WC. the pressure with appliances running was under 11"WC.

NOW my stove pressure downstream of the atwood regulator reads 11"WC.

time to call Atwood again, and deal with the tiny LP gas leaks in connection I disconnected to use the manometer.
tjpolsin is offline   Reply With Quote
Old 08-25-2014, 11:35 PM   #4
Senior Member
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,263
Let us know how your search turns out.
2011 Eagle 330RLTS with just about every option.
Dodge SRW 1 ton Cummins powered.

I was born with nothing and I still have most of it left.
clutch is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.