Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-18-2014, 04:57 PM   #1
Join Date: Oct 2011
Posts: 66
Electric stabilizer motor auto actuating

Yesterday morning packed up at the campground and off I went for home.

Two hours later I stopped for gas and while filling up I could hear a clanging sound that occurred for about a couple of seconds and repeated itself about every 30 seconds. I began to look around to see where the noise was coming from and finally discovered it was coming from under my fifthwheel. After closer inspection I could see the motor was trying to raise the already raised stabilizer in the back. I presume for some reason power was being applied to the stabilizer motor until a thermal in the motor cut out , and the cycle would repeat itself once the thermal cut back in. Anyone ever have this happen, if so what was the fix? The unit is a 2012 Eagle Superlite 305


kiwaon is offline   Reply With Quote
Old 06-18-2014, 05:00 PM   #2
Senior Member
TNCraig's Avatar
Join Date: Apr 2014
Location: Dayton
Posts: 376
Sounds like your extend/retract switch may be stuck in the retract position or broken. I would check there first

Craig & Terry in Tennessee
2013 Pinnacle 36 KPTS, Voyager Rear View Camera
2012 F350 CC LB King Ranch, 6.7L TD, Ford 25K hitch, TM TPMS, Diesel Site Coolant Filtration System

TNCraig is offline   Reply With Quote
Old 06-18-2014, 10:49 PM   #3
Senior Member
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,263
X2 on the switch. If it is like mine it is mounted at the rear of the trailer and it can get dust in it. I would flip it from extend to retract a few times and see if that fixes it.
2011 Eagle 330RLTS with just about every option.
Dodge SRW 1 ton Cummins powered.

I was born with nothing and I still have most of it left.
clutch is offline   Reply With Quote
Old 06-19-2014, 07:45 AM   #4
Senior Member
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 2,526
If you have the wireless remote control for slides, stab's etc it's possible that the wireless control board has gone bad. There was a recent post where the slide would activate on its own.

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:21 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.