Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-25-2016, 08:56 AM   #1
Junior Member
 
Join Date: Jun 2016
Location: Lancaster
Posts: 1
Furrion dv3200

We just purchased our new Jayco jay flight 27bhs yesterday, we love it!! However small issue, has anyone else had problems with the DVD player it's the furrion DV3200. It won't insert DVDs all the way then it just spits it back out?
__________________

Jaycostar is offline   Reply With Quote
Old 06-26-2016, 09:31 AM   #2
Senior Member
 
Wireman's Avatar
 
Join Date: Dec 2015
Location: Murrieta
Posts: 368
23RLSW 4months old. Everything OK with ours so far. I installed a HDMI cable between the 3200 and the Samsung TV I put in.

1080 P quality picture from the DVD player. I also connected a cable with a 3.5mm audio plug on 1 end into the TV and with a R/W RCA plug on the other end into the audio in plugs on the back of the 3200.

Switch the input on the 3200 to AUX and you can play the TV sound thru the ceiling speakers.
__________________

Wireman is offline   Reply With Quote
Old 06-29-2016, 09:05 PM   #3
RAZ
Junior Member
 
Join Date: Jun 2016
Location: Parker
Posts: 19
We are having trouble with our DV3200 as well. I have no radio signal now. It just quit working one day. I checked the antenna connection at the back of the unit and it is firmly in place. Perhaps the antenna wire is disconnected from the external antenna. That is a bit more challenging to troubleshoot. I plan to hook up a separate antenna to test before disassembling the antenna on the roof.

Also, occasionally the unit will just freeze up. Only after hitting the reset button once or twice will it begin to cooperate again - without the radio, though.


I put a call in to Furrion today. We'll see how quickly they respond with a solution. I will update when I get a response from Furrion.
RAZ is offline   Reply With Quote
Old 06-30-2016, 07:17 AM   #4
Senior Member
 
Loosenuts's Avatar
 
Join Date: Jun 2016
Location: Kennesaw
Posts: 165
Hey, while we're talking about the DV3200, has anyone tried to play an MP4 video from a thumb drive plugged into the USB? The information I'm reading says it should play them but I'm getting an INVALID FORMAT error. I created these MP4's myself so I don't know if it's something that I did wrong or if it doesn't really support MP4 format. I can get it to play .AVI files fine.
__________________
Charles King
Kennesaw, GA
My 28RLS Mods and Observations

TT 2016 Jayco 28RLS
TV 2010 Chevy 2500HD 4x4/Z71 aka The Beast
Loosenuts is offline   Reply With Quote
Old 06-30-2016, 08:34 AM   #5
RAZ
Junior Member
 
Join Date: Jun 2016
Location: Parker
Posts: 19
I haven't tried MP4 files yet. Contact them for technical support as they are very responsive.


I called and submitted a support request online yesterday evening and I received a call this morning. Furrion is sending me a replacement unit. Great customer service!!
RAZ is offline   Reply With Quote
Old 07-06-2016, 10:41 AM   #6
Junior Member
 
Join Date: May 2016
Location: Longmont
Posts: 8
I had the same problem with my Furrion DV3200. I contacted Furrion, they quickly sent me a replacement. When I removed the "bad" unit (4 simple screws behind bottom snap-off panel cover) I discovered that there was a red strip of plastic on top of the unit that was held on by 2 simple screws. On the strip was printed "remove before installation". Removed the strip and tada! It works. Sent the "good" unit back with a follow-up email.
colodaddy is offline   Reply With Quote
Old 07-06-2016, 10:46 AM   #7
Junior Member
 
Join Date: May 2016
Location: Longmont
Posts: 8
Remove the unit (4 screws behind snap-off front panel) and then remove the red strip attached to the top of the unit (2 screws) . Strip says "remove before installation". Guess many of these were missed on installation.
colodaddy is offline   Reply With Quote
Old 07-06-2016, 11:06 AM   #8
Senior Member
 
Loosenuts's Avatar
 
Join Date: Jun 2016
Location: Kennesaw
Posts: 165
OMG! So much for Quality Control.
__________________
Charles King
Kennesaw, GA
My 28RLS Mods and Observations

TT 2016 Jayco 28RLS
TV 2010 Chevy 2500HD 4x4/Z71 aka The Beast
Loosenuts is offline   Reply With Quote
Old 07-06-2016, 10:44 PM   #9
RAZ
Junior Member
 
Join Date: Jun 2016
Location: Parker
Posts: 19
I had the unit out but I didn't notice a red strip. I'll have to check it out when the new unit arrives. Did you have radio at some point and then it quit? That's how mine went.
RAZ is offline   Reply With Quote
Old 07-07-2016, 07:36 AM   #10
Senior Member
 
Loosenuts's Avatar
 
Join Date: Jun 2016
Location: Kennesaw
Posts: 165
Quote:
Originally Posted by Loosenuts View Post
Hey, while we're talking about the DV3200, has anyone tried to play an MP4 video from a thumb drive plugged into the USB? The information I'm reading says it should play them but I'm getting an INVALID FORMAT error. I created these MP4's myself so I don't know if it's something that I did wrong or if it doesn't really support MP4 format. I can get it to play .AVI files fine.
FWIW: Must be something about the file types. I realized the ones that weren't working were not created by me. The ones that I ripped myself from my DVD's work fine.
__________________

__________________
Charles King
Kennesaw, GA
My 28RLS Mods and Observations

TT 2016 Jayco 28RLS
TV 2010 Chevy 2500HD 4x4/Z71 aka The Beast
Loosenuts is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.