Jayco RV Owners Forum

Thread Tools Display Modes
Old 03-31-2013, 06:45 AM   #11
Senior Member
RoyBraddy's Avatar
Join Date: Sep 2011
Location: King George
Posts: 2,124
That might account for the lights coming back on in the middle of the night hehe... Good point Mr Doug... I have had problems with my 2008 Starcraft ceiling lights push button switch under the sink as well... All those things sure take a beating it seems.

Of course he might have a live-in ghost too...

I am going to setup my tent trailer this next coming weekend here at Camp Backyard and give it a good shake down and re-stock all the items. At least locate all of the items I usually carry on the trips. I have been looking for my Sears Clamp-on AMPMETER all winter long - Sure hope that falls out of box in the POPUP. I'd rather find all of the loose ends here at the house before heading out on the road somewhere...

Looks like my two each standard issue 12VDC GP24 Interstate batteries made the winter ok - They looking good on their state of charge. Don't think this 170AHs of batteries is going to do me very well. I have been getting by just fine with three batteries (255Ahs) but lost one last season. Started out with four 85AH batteries in 2008 and down to two now - Not all that bad for five years of use I reckon. Most of the trips was camping off the power grid as well. Its about time to go for a whole new set of something...

Roy Ken

Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Old 03-31-2013, 05:27 PM   #12
Junior Member
Join Date: Mar 2013
Posts: 5
Sorry and thank you guys. You guys are great.
Power is back. I reseted the breaker. I was so stupid. I just pushed a little harder and it worked.
Sorry I forgot to tell you the Model, its a 1207.

I will send more infos about the furnace when I'm back home. Right now the night temperature is back in the 60's so I don't need it.

blacky is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:06 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.