Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-09-2016, 03:18 PM   #11
Join Date: Dec 2015
Location: Beaverton, Oregon
Posts: 65
Also, the "positive" wire will have a larger diameter connector than the "negative" wire. The positive post on the battery is larger diameter than the negative post.

I also agree with BuddyRay that "it looks like the wire that goes through the empty fuse holder and three crimp connectors is probably your breakaway brake switch and goes on the positive terminal of the battery. For the other two, red is positive white his ground."

If it were me, I'd hook it up to a fully charged battery making sure the larger connectors with the red wires are attached to positive terminal on the battery and the white wire with the smaller connector is attached to the negative terminal and see what works first. Then decide if you need to trouble shoot further or re-do wiring. It could be that everything works just fine.

2016 Jayco Whitehawk 27DSRL
2010 Ford F-150 XLT Supercrew with Max Tow
WyEm is offline   Reply With Quote
Old 06-09-2016, 03:44 PM   #12
Senior Member
Join Date: Aug 2015
Location: Ottawa, ON
Posts: 548
That is a bit of a mess. A couple of additional suggestions:

It looks like the fuse holder with the 20A is on the wire to the breakaway switch. Anyone ever seen a fuse on a breakaway? Seems to me that this is wrong! If your trailer breaks away, you want full power to the brakes stopping the trailer. If they draw too much current for some reason, and the fuse blows, no e-brakes at all.
The wire for the main disconnect fuse (missing) seems awfully small gauge. For a pup trailer, I would expect that this would be a 20A fuse most likely, but that is a pretty small gauge wire for 20A. Wondering if the wire would melt before the fuse blew... I'd be wanting to upgrade that.
I'm also wondering where the battery box mounts on here. If it is in front of the LPG tank, it doesn't look like those wires will reach?

2011 Jayco X19H (purchased 2015)
2008 Jayco 1007 PUP (purchased new, traded for the X19)
2012 Chev Traverse LT with TP
bankr63 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.