Jayco RV Owners Forum

Thread Tools Display Modes
Old 01-26-2015, 08:55 PM   #1
Senior Member
jerdog's Avatar
Join Date: Dec 2014
Location: Southern CA
Posts: 192
Water Leak under pressure

OK, we discovered this past weekend that when hooked up to city water at an RV park we have a leak coming out under where the fridge is and along the wall on our 2001 Jayco kiwi 17A. I'm using a regulator at the hose bib.
Also, we could hear a slight "buzz" or "hiss". I went ahead and disconnected the city water hook up and filled the water tank and used the pump the rest of the weekend and it quit leaking. Any ideas? Simple fix or high dollar repair?

jerdog is offline   Reply With Quote
Old 01-26-2015, 09:29 PM   #2
Senior Member
Tunce the traveler's Avatar
Join Date: Aug 2013
Location: Bellingham,Wa.
Posts: 3,839
Could be a faulty regulator and or a loose connection.Either the screw on ( just tighten with your fingers) or the clamp type. I carry 4 hose clamps ( like the ones that are used on your car water hoses). So far I used one.
Tunce the traveler is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:54 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.