Jayco RV Owners Forum

Thread Tools Display Modes
Old 10-25-2012, 06:01 PM   #11
Senior Member
Join Date: Oct 2012
Location: Oakland County, MICH
Posts: 185
Originally Posted by tnchuck100 View Post
Let me add to what norty said. You should operate EVERY system in EVERY mode that your RV has at least once a month. The only exception would be the fire extinguisher. But check that anyway.
As silly as that sounds, you're absolutely right. I should check out every system/function of my TT; sadly, I have not. I'm always leery of breaking something. Thanks for the advice. I know what I'll be doing this weekend!!

2015 Jayco 32 TSBH
2015 Ford F-150 3.5 EcoBoost
Equi-l-zer WDH
pm1stnau is offline   Reply With Quote
Old 10-25-2012, 10:40 PM   #12
BluJay's Avatar
Join Date: Apr 2011
Location: Fort Wayne
Posts: 52
Send a message via ICQ to BluJay

I also don't believe there is a dual system water heater option on X17s. Added the following "hybrid" kit to my LP-only X17Z, which gives me the option of LP, electric, or both. Fairly easy to install, too.



Fort Wayne, Indiana
TV = 2013 Toyota Highlander
BluJay is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:53 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.