Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-12-2011, 09:17 PM   #11
Senior Member
Join Date: Apr 2011
Posts: 136
I've had lots of defects over the years, and in every case but one the manufacturer was prompt in addressing the problem at their expense...except for one company. Kwikee is the notable exception. They don't even HAVE a customer support number.

I had a 2008 Winnebago Access 31c. The Kwikee power step was not operating as per the instructions, and the defect eventually fried the chassis battery within a year. They digisync power slide was also manufactured by Kwikee. It died in the middle of the second year. Had a forum like this existed, I may have had some leverage with the dealer to have the problems fixed. Or better yet...I may have avoided that product completely. Great idea to start this thread!!!

RustyFairmount is offline   Reply With Quote
Old 05-13-2011, 02:03 PM   #12
Senior Member
Join Date: Oct 2009
Location: Calgary Alberta
Posts: 512
Originally Posted by healthi View Post
Your welcome

Snowbirds Forum... wasn't going.... It would be a nice addition so l'll look into it. Give me a day or two
Thank you, Rolly was going to look into some time back so I thought I would ask again.

2007 Jayco Eagle 325BHS
2010 Dodge 3500 Laramie
Kipor 2000 Generator
Albertaguy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.