Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-05-2016, 05:14 PM   #1
Junior Member
Join Date: Jul 2016
Location: East Helena
Posts: 2
174BH Interior Lights Issue

We recently purchased a 2016 Jayco 174BH. Had it out this weekend and strange thing happened to interior lights. When plugged into power supply at campground, the radio stopped working in the afternoon on Monday and then that evening the lights started going haywire. Would turn on the main light switch and one light of the three would turn on. Would turn on one and another would go out. Or, get all three on and after a while, the one by the bunk would go out. If you turned on the outside light, the interior lights would go out. Very strange. However, microwave, fridge and AC unit work just fine.

When it is not plugged in and running off battery power, there is no issue. Very strange. Have a call into service department but they can't get to it for a while.

Any information, help, insight would be greatly appreciated.

bigsky12 is offline   Reply With Quote
Old 07-05-2016, 07:40 PM   #2
Junior Member
Join Date: Jul 2016
Location: East Helena
Posts: 2
Solved the issue. Had a loose connection to a wire. Thanks.

Mods can delete this thread if they want.
bigsky12 is offline   Reply With Quote

174bh, electric issue, interior lights, lights

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.