Jayco RV Owners Forum

Thread Tools Display Modes
Old 03-21-2014, 09:27 AM   #1
Junior Member
Join Date: Mar 2014
Location: Hudson
Posts: 2
Question A/c Not Blowing Hot in FL! :(

This morning I went to turn on the a/c , I hear a loud humming sound but its not blowing cool air? Do these things run on Freon and need to be re-charged???
When I click to fan that works fine.

ReptileDiva2010 is offline   Reply With Quote
Old 03-21-2014, 09:49 AM   #2
Senior Member
mcfarmall's Avatar
Join Date: Jun 2011
Location: Kalamazoo, West Michigan
Posts: 1,815
If the compressor isn't starting it won't blow cold air. Perhaps the start capacitor is bad. I've had to replace one or two on some residential A/C units in my life.

2006 23B Hybrid with 10k round bar WDH
2011 F150 4x4 SCREW Ecoboost, Max Tow, Integrated TBC, 3.73 LS axle, Firestone Ride Rite airbags.
mcfarmall is offline   Reply With Quote
Old 03-21-2014, 09:54 AM   #3
Senior Member
RoyBraddy's Avatar
Join Date: Sep 2011
Location: King George
Posts: 2,125
Usually this is an indication that the 120VAC INPUT level from the camp ground pedestal is too low for your air conditioner compressor.

I use one of these plug-in 120VAC METERS in a good spot where I can glance at it to check the 120VAC LINE VOLTAGE before turning on the Air Conditioner. If the LINE VOLTAGE is not within the MARKED GREEN SAFE ZONE then I will not turn on the Air conditioner. Pick one up from local RV store or AMAZON.

Continuing to power-up the air conditioner if all you hear is a loud hum may damage your compressor motor.

The RV Air Conditioner Compressors are usually not equipped with FREON TEST PORTS for A/C repairman to use.

Roy Ken
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Old 03-21-2014, 10:26 AM   #4
Junior Member
Join Date: Mar 2014
Location: Hudson
Posts: 2
Thanks for all the help !

From what I have been told by the place I got My Eagle from ... it sounds like the compressor I cant complain this is our 1st major repair just scared to see the price tag !
ReptileDiva2010 is offline   Reply With Quote
Old 03-21-2014, 10:46 AM   #5
Senior Member
Join Date: Nov 2012
Location: Iowa
Posts: 336
I had the blower motor go out on mine last summer, in July. Took it to the dealer and they fixed it. Won't know till summer if fixed. It lasted about a month.
1998 Chevy Dually
2013 Jayco Premier Eagle 361REQS
Cruzinfools is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:13 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.