Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-04-2016, 01:54 PM   #1
Junior Member
 
Join Date: Aug 2016
Location: Bend
Posts: 5
Furnace not working

I sifted through some furnace threads but could not easily find my answer. Thought I'd include all the specifics leading up to my problem in case it helps diagnose the problem.
I have a 2006 model 1007 tent trailer with Atwood furnace (if need to include model # will do). Everything working fine for 3 seasons.
This year was the first time I plugged into electrical service at campground as I usually disperse camp. On this trip I also had a leak at the propane hook-up, detected after I hooked up.
Furnace fan and heat ran 1 time, but after that I could get neither fan or heat. Once I detected gas issue I disconnected from gas for rest of weekend.
I have tried to operate furnace 2 more times since, once by battery hook-up and once plugged in. I can hear the click when I advance the thermostat, but get no fan or heat. All other outlets and lights work, as well as outdoor grill, water heater and gas to fridge (no more leak after changing tanks).
I checked circuit breaker and all fuses - all seem to be operational.
Any thoughts?
__________________

familycamp is offline   Reply With Quote
Old 09-04-2016, 02:00 PM   #2
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,475
Pull cover off of the heater and check the high limit switch, You should be getting the fan to run for a minute or so before the flame will come on The fact you are not getting the blower to come on when you call for heat leads me to think the high limit is tripped
__________________

__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Old 09-04-2016, 02:01 PM   #3
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,475
Also post the model number
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Old 09-04-2016, 02:08 PM   #4
Junior Member
 
Join Date: Aug 2016
Location: Bend
Posts: 5
Thanks for the help.
Model # 7916-11
How do I identify the high limit switch?
familycamp is offline   Reply With Quote
Old 09-04-2016, 02:12 PM   #5
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,475
If you can look up the model and you should be able to down load the manual
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Old 09-04-2016, 02:23 PM   #6
Junior Member
 
Join Date: Aug 2016
Location: Bend
Posts: 5
Have the manual up now. What would I be looking for with the switch?
familycamp is offline   Reply With Quote
Old 09-04-2016, 02:51 PM   #7
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,475
you will see the high limit switch Its a round object may be black or red with two wires on it also check the circuit breaker inside of the heater The wiring diagram should give you some idea what to look for If you have a meter handy it would be helpful
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Old 09-04-2016, 02:52 PM   #8
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,475
http://www.google.com/url?sa=t&rct=j...31783435,d.eWE


look at page 8 and page 30
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Old 09-04-2016, 05:56 PM   #9
Junior Member
 
Join Date: Aug 2016
Location: Bend
Posts: 5
bedrck46, thanks for your help. Found the switch, hit reset on the breaker, all wires appear intact. Unfortunately this is where my limited electrical knowledge is surpassed. Will have to have it serviced. Appreciate your time.
__________________

familycamp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.