Jayco RV Owners Forum

Thread Tools Display Modes
Old 04-19-2014, 10:57 PM   #1
Junior Member
Join Date: Apr 2014
Location: Arroyo Grande
Posts: 4
2010 Seneca marker lights not working

I just purchased a 2010 Seneca and love it! But the marker lights on the front and back are not working. The ground is good but no power. I am trying to find out where the wiring goes from the frame to the top of the body. Or is there a hidden blower fuse?

I need some help. Does any one have some ideas wher the power wire is located. Jayco factory told mad that the lights are wired in series. I hooked up power and all of the lights turned on. So the power wire is disconnected somewhere or a fuse is blown. I checked all fuses and all good.

Help. I appreciate the forum input.

Rugged1 is offline   Reply With Quote
Old 04-20-2014, 09:10 AM   #2
Site Team
FPM III's Avatar
Join Date: Nov 2010
Location: Fayette Ridges of PA, USA
Posts: 2,131
Welcome to JOF!

Marker lights wired in series? I find that hard to believe. Just thinking logically about it, if you used 12V lights in in series for the marker lights of an RV, they would glow very dimly and also create a serious safety hazard if they all went out when one failed. Surely this person misinformed you. I've had marker lights on my TT (and TV) go out, but all the others remained lighted.

Unfortunately, I'm not familiar with the Seneca so I won't be able to answer your question. However, I'm confident that someone who owns one will be able to offer assistance.

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search

TV: 2009 GMC Sierra 2500HD | Crew Cab | Std. Box | 4WD | Duramax/Allison
RV: 2000 Jayco Eagle 266 | FBS | TT -- 1986 Coleman Laramie pop-up -- Still in the family!!!
FPM III is offline   Reply With Quote
Old 04-20-2014, 11:47 AM   #3
Senior Member
Grumpy's Avatar
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 3,523
The front marker lights and the rear marker lights are actually seperate. There is a momentary switch on the dash to the right of the radio with a light symbol on it that will flash the rear clearance lights (just like the semi's). Based on what you are saying it sure sounds like a bad fuse or relay in the chassis wiring which would be a Chevy issue.
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 04-20-2014, 03:39 PM   #4
Junior Member
Join Date: Apr 2014
Location: Arroyo Grande
Posts: 4
I checked the switch on the dash and the relay. All works good. Still no marker lights. I hooked up 12v to one marker light and they all come on. So all of the lights are working.

This still tells me the main power wire is not working. Does anyone know where the wiring goes from the frame to the coach? Anything would be helpful.
Rugged1 is offline   Reply With Quote
Old 04-26-2014, 04:26 PM   #5
Join Date: Jun 2013
Posts: 70
Mostly on the seneca they run in the frame of the chassis
greyhawk885 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:05 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.