Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-12-2012, 12:27 PM   #1
Junior Member
Join Date: Jul 2012
Posts: 23
back up monitor not powering on. where to look for fuse?

hi all,

the backup monitor on my 2007 31ss just stopped working. it worked fine and now it's not powering on at all, even in reverse. i suspect it's a fuse, but where do you look?


hayaku is offline   Reply With Quote
Old 08-12-2012, 02:07 PM   #2
Junior Member
Join Date: Jul 2012
Posts: 23
nevermind.. i found them.

there are glass fuses located right above the parking brake release handle. just pull off the plastic skirt under the steering wheel and you have full access to them.

they are red, blue, and brown. my brown was not connected to anything. these are inline glass fuses in white plastic housings. red for power. i assume blue is the reverse trigger.

the red was joined to one of the blue plastic fuse box things. there are 2 blue fuse box things. both are connected to an orange power lead from a harness plug right there. only the orange lead is being used and everything else was crimped off.

very easy to replace the fuse if you need to.

hayaku is offline   Reply With Quote
Old 08-13-2012, 02:10 PM   #3
Join Date: Aug 2011
Location: Tualatin Oregon
Posts: 43
I hate those glass fuses, in this day and age why are those put into our units?
quadnkev is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:20 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.