Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-21-2011, 04:48 PM   #11
Junior Member
Join Date: Jun 2011
Location: Chandler, Arizona
Posts: 10

Thanks for the welcome and I will eventually get around to introducing myself. I am glad to hear I am not the only one with this problem, but I am disappointed that these kind of things even happen at all. It was scary to say the least, but all is working out okay for now!

Arizonaeagle is offline   Reply With Quote
Old 06-22-2011, 09:02 PM   #12
Junior Member
Join Date: Apr 2011
Posts: 4
Wow! That is one heck of maiden voyage. We will be taking ours this coming Friday. We got this rig in late April and have learned a lot about it just "camping" in the driveway. One such weekend we tired our "pizza and a movie" night and used the microwave for the first time. It got VERY hot cooking the pizza and in fact at one point tripped our shore line power source hooked up in the garage. I would be interested in knowing what actually started the flame in your unit.

Since we bought our unit used, we had time to notice there was no fire extinguisher installed. We paid for that installation item at our "last chance to make right" 30 day warranty with the dealer. Now I wonder why it was missing in the first place and the microwave looked never used... maybe the same thing happened in our unit (Mel. 29C) as did in yours, Arizonaeagle. I also wonder if there is an "incident report" for this stuff on line?

Do let us know any updates and I will do the same. Take care and so glad you all were safe and you did the right thing without a panic.

Kate, Lynn and James
2009 Melbourne 29C

Happy Clam is offline   Reply With Quote
Old 06-26-2011, 08:52 PM   #13
Junior Member
Join Date: Jun 2011
Location: Chandler, Arizona
Posts: 10

Tomorrow will be a week since I took it back to the dealer for repair. They just umplugged it and said they would be in touch with Jayco. As of last Friday, June 24th, Jayco had not responded to the dealer so I am sitting here in limbo waiting and will be leaving for Colorado on the 6th of July...just over a week away. I guess I will be in Durango without a microwave and oven.
Arizonaeagle is offline   Reply With Quote
Old 06-27-2011, 06:44 AM   #14
Senior Member
The Hawk's Avatar
Join Date: Mar 2011
Location: Stockton, CA
Posts: 128
I would be all over the dealer and demanding to get it right and also be taking the problem to Jayco. The dealer's seeming lack of interest in overcoming this serious warranty problem should also be noted! These are things a manufacture does not like to delay in dealing with. LET JAYCO KNOW
The Hawk is offline   Reply With Quote
Old 06-27-2011, 10:31 AM   #15
Senior Member
Terry's Avatar
Join Date: Feb 2011
Location: Germantown, TN
Posts: 4,923
Not to say it is not Jayco causing the delay, but I have seen dealers use that tactic (saying it is Jacyco) when in fact the dealer is the cause of the delay. You are within your rights to call Jayco directly and ask the status. Have your VIN ready.

2009 Jayco 26BH
2004 Chevy Silverado 1500
2009 JayFlight Manual Library

Want to add a signature to your posts? --> Click Here
Terry is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:27 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.