Jayco RV Owners Forum

Thread Tools Display Modes
Old 11-22-2015, 05:50 PM   #1
Junior Member
Join Date: Jul 2014
Location: Bonaire
Posts: 29
Intermittent heater settings

I went through the heater experience like a lot of other folks I have read about on the forum. Thermostat goes to 00 and the resets to 72. Took it to CW and they said they put in an isolation transformer and this cured the problem. My problem was by the time I got it back, I didn't need the heater any more so I never checked it. My bad. Calling for freezing temps tonight so I turned it on only to find out I have the same problem as before. Anyone know where this transformer is located so I can see if it really was installed or is there another problem here as well.


Rick and Janet Harris
2015 Greyhawk 31DS
tow 2014 Honda CRV

rickyd53 is offline   Reply With Quote
Old 11-23-2015, 05:11 AM   #2
Join Date: Oct 2013
Location: Central Wisconsin
Posts: 94
The panel to access my furnace is under the fridge. Remove the panel and look inside. You should see the isolation relay connected between the existing wires. If they did install it, it's possible that a connecting wire came loose.
2015 Jayco Greyhawk 29KS
Roadmaster 2000-1 Tow Dolly
JulieMike is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:40 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.