Jayco RV Owners Forum

Thread Tools Display Modes
Old 12-08-2015, 02:25 PM   #1
Junior Member
Join Date: Aug 2015
Location: Cedar Falls
Posts: 7
Leveling jacks

It is me again. We had a problem with our leveling jacks last trip out. We took it to CW of Cedar Falls and were told it was because the coach batteries were getting low. They cleaned the connections and everything worked. Has anyone else had this issue?

2014 Seneca 36FK
Ausshepard is offline   Reply With Quote
Old 12-08-2015, 04:54 PM   #2
Senior Member
Join Date: Aug 2015
Location: Carencro
Posts: 102
Just had an issue in my 2014 where the left rear wouldn't raise on first try. I fiddled with switch, recycled it, and it started working.

I emailed Quadra Tech Support today for the required PM steps. Prompt response. They recommended some dielectric lube in the switches as we as some dry lubricant or teflon spray on the shafts of the cylinders. I'll do that this weekend.

2014 Jayco Seneca 37FS
tjbroussard is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:16 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.