Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-07-2011, 07:54 AM   #1
Junior Member
Join Date: Jun 2011
Posts: 10
Lo D/C Lo A/C on Ref

I keep getting a LO D/C and LO A/C warning on my ref. Anyone have a simular issue and what fixed it? Had the inverter checker it is good. I notice the cord that plugs in to ground power blades are discolored from arcing and was wondering if that could cause it. I cleaned them off but got it again this morning. The on-board indicator says the batteries are full the but the ref says otherwise. I plugged in the maintenenace charger to be safe and not lose food while at work. I am going to Sturgis in a few weeks and want to make sure it is a uneventful trip other than the beautiful views. This is beginging to baffle me.

darzoom is offline   Reply With Quote
Old 07-23-2011, 12:52 PM   #2
Junior Member
Join Date: Apr 2011
Location: Bloomington Indiana
Posts: 4
Hey Darzoom

This sounds like an open ground at your receptacle. Check both ends, at the receptacle and at the breaker box. You didn't say how old your camper is, if it's very old you might have a loose, broken, or corroded ground strap at the frame. Hope this helps! keep us posted.

flyboy is offline   Reply With Quote
Old 07-23-2011, 03:35 PM   #3
Senior Member
Join Date: May 2010
Posts: 552
What does your owner's manual say about the codes? That's where I would start.
2010 22FB(Ret)
2013 F250 XLT
I now have a Keystone Outback, but I try to help when I can.
Bitter Gun Owner
Bitter Clinger
Armed Infidel
Bob Landry is offline   Reply With Quote
Old 07-24-2011, 07:52 AM   #4
Senior Member
Join Date: Oct 2010
Location: Merrimack NH
Posts: 781
darzoom--- One problem is the female receptical you are plugging into, if your blades are turning blue, from excessive heat, the female recpt .has losing it's tension on your blades. You may want to advise the cg owner so the recpt can be changed. Larry
Larry & Rachel Demers 2010 19H, 1999 F250 std cab 5.4, Auto, 4:10's 4x4
19H F250 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.