Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-26-2015, 05:19 PM   #1
Senior Member
Join Date: Oct 2014
Location: Western NY
Posts: 223
Turn lamp

We were in Piegon Forge the other day and my DW was following in a rental car. She noticed our driver's rear signal / stop light was not working. It was a simple fix, but my concern is that I had no indication in the cab. My past experiences is that when a signal is not working the blinker in the dash does not work.

Anyone with similar experience? Is this the result of Jayco's build out of the Ford frame?

'16 Coachmen Mirada 35BH

Formerly 31FK 15 Grayhawk
Toad: 2015 Jeep Cherokee "The Caboose".

Taking in the sights wherever my Trolley takes me!
WDW is offline   Reply With Quote
Old 07-26-2015, 05:45 PM   #2
Senior Member
Grumpy's Avatar
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 3,513
Originally Posted by WDW View Post
Is this the result of Jayco's build out of the Ford frame?
Typical E-450 cutaway chassis. They are designed for MH, buses, ambulances, etc.
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:13 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.