Jayco RV Owners Forum

Thread Tools Display Modes
Old 09-08-2016, 10:15 AM   #31
Senior Member
Join Date: Jun 2015
Location: smithville, ont.
Posts: 1,147
I'm sure it's been checked, but there were a couple guys here that took apart the unit and found the returns were not connected.
That would cause cooling issues.

Only 1 unit would cause only a mediocre cooling on a hot day in a big rig like that.
That's why they offer 3 units now.

Good luck.
They really are a pretty good 5th wheel for the most part. I have very few problems.

2016 North Point 341RLTS
2012 F-350 Lariat CC SRW
klassic is offline   Reply With Quote
Old 09-13-2016, 09:09 AM   #32
Junior Member
Join Date: Jan 2016
Location: Jeffersonville
Posts: 1
Long time lurker, but inspired to make first post. Like Lakehouse, we too live in Jeffersonville and have a 377RLBH with AC cooling problems. (small world) We are also having issues with our unit cool below about 5 degrees above ambient. We have the front unit as well. The only way we can get our unit tolerable in higher temperatures is to run a box fan from the front bedroom (with the AC set extremely low so that it will not shut off). Also, we keep our unit permanently parked at a seasonal site year round. It is under a full roof with sides that extend about 6' down the side of the camper. We are entirely in the shade.

The dealer has been great to work with but we still don't have what we would consider a properly air conditioned unit (especially at this price point). After the dealer did all of the checks that Jayco asked them to do, I contacted Travis in Jayco customer service department. He had me remove the collars inside the vents. The collars probably reached 2/3 the way up into the ducts (so I am sure they were restricting airflow). Unfortunately, I have not been at the camper during a hot weekend to try the system out since then. I believe we did get more air flow, but I am not optimistic that this will give us relief. This is our 3rd Jayco camper. I have been very satisfied with their quality and service in the past. I fully expect we will get something resolved. The fact that there seems to only be a couple of us with this issue makes me think it is something simple. Also, thankfully, we have not had any other major problems....just the AC inadequacies.

Could someone point me to the thread with concerning the return units not being hooked up completely? I would be interested in researching that possibility.

brian918 is offline   Reply With Quote

defects, doors, lights, slides

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:45 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.