Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-17-2016, 08:25 PM   #1
Junior Member
 
Join Date: Oct 2016
Location: Bozeman
Posts: 5
2016 Pinnacle heat not working

Hi, my dad just bought a 2016 Pinnacle and we just got it back from rv shop from getting a washer and dryer in it...got it back to rv campground and can't get heat to turn on...I checked propane its full...ac works just not heat...I'm sure I'm not doing something right but I looked at jay of manual not much in troubleshooting ideas...so that's why I'm hoping for someone to have an idea!!!!
__________________

Alexander765 is offline   Reply With Quote
Old 10-17-2016, 08:29 PM   #2
Senior Member
 
abarkl's Avatar
 
Join Date: Nov 2015
Location: Phoenix, AZ (2008 Seneca 35GS Diesel)
Posts: 844
What symptoms including any relevant noises have you observed after turning on and setting the thermostat for Heat?
__________________

abarkl is offline   Reply With Quote
Old 10-17-2016, 09:13 PM   #3
Senior Member
 
TexasRT's Avatar
 
Join Date: Mar 2015
Location: Pasadena
Posts: 413
Are you trying to run the gas heater or the heat pump?
__________________
2015 Pinnacle 36FBTS
2015 F250 SD Platinum 4x4 - 6.7L PSD :
Titan 50 Gal. Fuel Tank
Slotted and Dimpled Brake Rotors
Air Lift LoadLifter 5000 Ultimate Airbags with WirelessAIR Controller
TexasRT is offline   Reply With Quote
Old 10-18-2016, 09:02 AM   #4
Junior Member
 
Join Date: Oct 2016
Location: Bozeman
Posts: 5
Hi, thanks for taking time to respond it's the gas heat!
Alexander765 is offline   Reply With Quote
Old 10-18-2016, 09:04 AM   #5
Junior Member
 
Join Date: Oct 2016
Location: Bozeman
Posts: 5
no noises at all...that's why I feel it's human error but just don't know...I have gas going to stove so know it's not propane regulator. Thanks for taking time to respond!!!
Alexander765 is offline   Reply With Quote
Old 10-18-2016, 09:14 AM   #6
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,511
Quote:
Originally Posted by Alexander765 View Post
no noises at all...that's why I feel it's human error but just don't know...I have gas going to stove so know it's not propane regulator. Thanks for taking time to respond!!!
1) Check that the thermostat is set well above room temperature, it may not be calling for heat.
2) Check fuse for the heater at the converter
3) Access the heater cabinet from inside the RV and look for a switch that may have been accidentally turned off.
4) If it failed to light once, you'll have to power-cycle it to get it to retry.
__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 10-18-2016, 09:57 AM   #7
Junior Member
 
Join Date: Oct 2016
Location: Bozeman
Posts: 5
Thank you, thank you! Sorry to ask more questions... How do I do a power-cycle?
Alexander765 is offline   Reply With Quote
Old 10-18-2016, 10:07 AM   #8
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,511
Quote:
Originally Posted by Alexander765 View Post
Thank you, thank you! Sorry to ask more questions... How do I do a power-cycle?
Sorry, techie speak.

"Power cycle" means turn it off, wait a few seconds then turn it back on.

"Reboot your heater" sounds even more peculiar.
__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 11-19-2016, 03:02 PM   #9
Junior Member
 
Join Date: Jun 2016
Location: Mt Juliet
Posts: 13
Send a message via AIM to Bauernfeind
Did you get the heat to work? What was it b/c I'm having the same issue
Bauernfeind is offline   Reply With Quote
Old 11-19-2016, 03:43 PM   #10
Junior Member
 
Join Date: Oct 2016
Location: Bozeman
Posts: 5
Hi! No I am no help...we still don't know what it is...so we took it into our local jayco dealer they did a quick look at it said they couldn't find anything but needed us to schedule time ...so anyway we got home it was working when my dad got it home...the mechanic did tell us sometimes a good slap to the furnace will reset it..maybe driving it around did that...but I wish I could be more help...we did call jayco directly they did help us find the furnace and answered questions if you haven't already try that or these smart guys on this site will give ya help!
__________________

Alexander765 is offline   Reply With Quote
Reply

Tags
2016, heat, pinnacle

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.