Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-31-2016, 07:20 AM   #11
Join Date: Jun 2015
Location: Canastota
Posts: 49
I had a dead outlet by the stove and it was a bad connection at the microwave fixed under warranty

Sent from my iPhone using Tapatalk

UpstateNY-31FS is offline   Reply With Quote
Old 05-31-2016, 07:33 AM   #12
Senior Member
JFlightRisk's Avatar
Join Date: Apr 2012
Location: Newark
Posts: 499
Originally Posted by jasum View Post
Tv outlet, outlet above tv & side countertop outlet all not working.
Any ideas??

Just to throw out something that happened to us. Many years ago on another brand of TT, we lost power to a few outlets. As it turned out, the wires were pushed into the back of the outlets, instead of being connected to the screw terminals. The positive wire on an outside outlet had lost connection, and every other one downstream from it was dead. Reconnection of the wires to the screw terminals solved the problem. I haven't taken out one on our TT yet, to see how the factory connects the wires. Just a far-out thought!

2012 Jay Flight 19RD
2010 Tundra TRD DBL Cab
1 Spoiled Dog
JFlightRisk is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:43 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.