Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-08-2016, 10:36 AM   #21
Senior Member
Join Date: Sep 2013
Location: South Texas
Posts: 3,625
Originally Posted by dgantz View Post
were sort of in the same boat, 2017 Greyhawk. We have brake lights but no turn signals.
Are the pins in the attch 7 pin connector picture the same on the e450 as the f150? if not where can I get the correct picture for pin location?
7-pin is standard; any available "map" should work. My truck has one right on the cover of the outlet

Originally Posted by citgodan View Post
X2 on cleaning the trailer connection with WD-40. I had a pin not making a good connection/contact with my truck's 7 pin box before. after WD-40 issues were gone.
I used dielectric grease on mine, though I didn't have connection trouble. I did it more to make the plug easier to operate and protect against corrosion. When it's not plugged into the truck, I have a little plug protector on the jack that keeps it protected and free of debris too.


2014 Jay Flight 28 BHBE
2015 RAM 2500 6.4L HEMI, Tradesman 4x4, 3.73
Blue Ox SwayPro (BXW 1503)

Upgraded from an REI internal frame backpack and a Eureka 1/2 dome tent!
Camper_bob is offline   Reply With Quote
Old 08-08-2016, 08:14 PM   #22
Junior Member
Join Date: Jul 2016
Location: Wilmington
Posts: 18
Found the back half had worked itself loose, pushed it back on and tightened, works great. I also used dielectric greese

Sent from my VS986 using Tapatalk

dgantz is offline   Reply With Quote

trailer exterior lights

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:31 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.