Jayco RV Owners Forum

Thread Tools Display Modes
Old 01-05-2015, 07:56 AM   #1
Junior Member
Join Date: Jan 2015
Location: Carterville
Posts: 2
Electric furnace not working properly?

It's set at 70. It's was 68 on electric and kicked on. dropped to 65! I switched it to gas and it is 70 in here and won't kick off!! Mind you it's beliw 0 here so I would prefer to run off electric to save propane! We just got our new Jayco 375BHFS so we are learning!

SparksFam is offline   Reply With Quote
Old 01-05-2015, 08:01 AM   #2
Senior Member
Jagiven's Avatar
Join Date: May 2012
Location: Minnesota
Posts: 3,186
Are you talking about the electric heat option on the roof top air conditioner? If so, I have never seen them come with the heater strip in them. It is about a $60-70 part. I have been thinking about adding it. We use a small 1500 watt ceramic heater. Place it on the floor in front of the oven at night and during the day if needed it sits on the stove.
Jagiven is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:29 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.