Jayco RV Owners Forum

Thread Tools Display Modes
Old 03-10-2016, 02:13 PM   #1
Junior Member
Join Date: Mar 2016
Location: Charlotte
Posts: 1
Fireplace heater not heating

My fireplace has stopped putting out heat in my Eagle Premier. Any suggestions?

CircuitRider is offline   Reply With Quote
Old 03-10-2016, 02:19 PM   #2
Senior Member
mike837go's Avatar
Join Date: May 2015
Location: Campbell Hall
Posts: 2,388
Fuses, circuit breakers. Double-check the setting on the thermostat.

After that, break out the ohmmeter and see how much magic smoke is left in the heating coils.

TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck

Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 03-10-2016, 02:26 PM   #3
Site Team
norty1's Avatar
Join Date: Jan 2011
Location: Charleston, SC
Posts: 9,398
Look up Dinkins. I called them direct and they sent me a control to replace a defective one. They even offered to send a mobile tech out to do the replacement. I elected to do it myself.

It was a learning experience doing it.
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:42 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.