Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-18-2014, 08:02 AM   #1
Senior Member
Join Date: Mar 2014
Location: New Haven
Posts: 258
Issues with auto leveling, new 5th

Ok. So I finally took a 3 hour drive to the dealer and picked up the new seismic and brought it back last night. Among a fee other issues (was somewhat of a rushed demo and will share thoughts on the dealer another day) I'm having issues with this leveling system. This is a Seismic 3914 with 6 points/actuators. It has an LCI panel with an Atwood "brain" and electrical actuators. When I attempt to auto level on a hard pretty level surface, (both axis within less than a couple degrees of level prior to leveling) when the rear jacks begin to raise the rear end they seem to struggle and the motors finally torque out and the panel will either shut off and turn back on and then give an error of "out of stroke" or just go to the error. What's interesting is the middle set of jacks don't do the kiss thee ground test nor do they move to assist the rear jacks. Thoughts? The test at the dealer seemed to go fine, although I was so overwhelmed and saturated given amount to take in and the pace I might have not noticed it errored out or was distracted. They did tell me if I screw up the sequence at all the system goes into confused and screwed up mode. I just think something's not right if the middle jacks don't move. Are they considered rear jacks as well and move in conjunction with the aft set? Long post I know. Thanks for any info in advance. I'm not happy at all about this obviously.

P25ct is offline   Reply With Quote
Old 05-18-2014, 11:57 AM   #2
Senior Member
Join Date: Mar 2014
Location: New Haven
Posts: 258
Update: spent a few hours with unit this morning. Made progress. Error in my first post, this is an LCI system, panel brain, ETC. I'm hitting out of stroke error because i extended the front landing gear extensions too much with the pin. So brought them up a few pin positions and it gets the front end lower so the rear jacks aren't trying to raise the back end to match the distance from the ground in the front. They were trying to raise the back end off the wheels. So I got unit level but still getting the out of stroke in back corner which still is nearing full travel. I found the mid body gear don't extend until auto level mode reaches auto level successful then it drops the mids to just add support without changing body angles. That's where I stand. Got to 0.1 left to right last try before rear jack hit the stroke error but got a green center light. Couple more times of trial and error and I should be good. System otherwise seems to be working as advertised. Anyone with experience with this, Id appreciate your input. Thanks in advance.
P25ct is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:29 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.