Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-23-2016, 07:21 PM   #1
Senior Member
Da Bud Man's Avatar
Join Date: Oct 2011
Location: Nicholasville, Ky
Posts: 169
Problem with New 325BHQS Norcold Fridge

So long story short, we took delivery of our new 325BHQS on Thursday July 14th, and left for Myrtle Beach for a week on Friday the 15th. During pdi, there was issue with the 12cu ft fridge throwing the L1 OP code which is something to do with high temp switch or something like that. They replaced the some board and all was fine, until we returned tonight, and it's out again! Luckily we had no issues while on vacation, but this is aggravating. We use this RV every weekend and our permanent lake spot.

Does anyone know of issues as to why it keeps killing this board? (sorry don't know what is called, but it's the small one next to the larger one on back of fridge)

Sent from my SAMSUNG-SM-T817A using Tapatalk
Kirk, Natalie, 2 Kids & 1 Dog
'14 Ram 2500 4x4 CC w/Cummins
'16 Jayco Eagle 325BHQS
'13 Suntracker PB 22
Da Bud Man is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.