Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-03-2013, 07:59 AM   #1
Join Date: Oct 2011
Posts: 98
2007 29bhs furnace not turning on, ac and fan works

Wanted to take the chill out of the camper today, turned on the heater and nothing. After about 30 seconds I could smell the electronic burning smell, which turned out to be the Hunter 42999B thermostat. I had used the furnace at the start of the season, not sure how to troubleshoot.

Have you successfully started any other gas appliances? Yes..

When you start the furnace, the fan should come on immediately (there's no wait time like the forced air gas furnace found in homes) blowing cold air. Does it? No...

If not, check your thermostat to ensure you have it set to Heat and the temperature is set high enough for the furnace to come on. Yes...

If that appears to be ok, check to see if the fuse for the furnace has blown. Nope...

Checked the control board, red light is not blinking.

The furnace runs on 12V DC so as long as the battery has sufficient power, it should run. We don't have a battery connected as the trailer is a seasonal.

Any suggestions?

I did hook back up the Coleman Mach thermostat and the heater didn't work.

Topher24 is offline   Reply With Quote
Old 08-03-2013, 10:58 AM   #2
Join Date: Oct 2011
Posts: 98
Discovered that the furnace wire was shorted when remounting the plastic plate for the digital thermostat. Now the AC won't engage.. well it sounds like it wants to kick in, but doesn't fully kick in.
Topher24 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:34 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.