Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-22-2015, 09:34 AM   #1
Junior Member
Join Date: Mar 2015
Location: Roy
Posts: 9
264 BMW AC question

We bought our camper in February of this year and have had a few issues, but have overall pretty much enjoyed it. I took it out last weekend and had to us the AC for the first time. I honestly could not tell if it was working or not. I had it on high cool and the temp setting all the way cold. I came into the trailer after it running for a couple of hours and the temp inside was barely different from outside. It felt like the air was cool but not cold. I could not hear a difference when I switched it from fan only to cool. The first day I also noticed no condensation coming off the roof so I was thinking the compressor b was not working. However the next day I did notice some but it wasn't any cooler. Has anyone else had this problem? I am going to take it in but I don't want them to tell me it is working fine.

csorton1029 is offline   Reply With Quote
Old 06-22-2015, 09:37 AM   #2
Junior Member
Join Date: Mar 2015
Location: Roy
Posts: 9
Title supposed to say BHW but auto corrected to BMW.

csorton1029 is offline   Reply With Quote
Old 06-22-2015, 09:42 AM   #3
Senior Member
mike837go's Avatar
Join Date: May 2015
Location: Campbell Hall
Posts: 2,387
I kinda thought that shipping and RV from Germany was a bit much....

You definitely do not have an operating compressor.

Whether it is the thermostat, the compressor, a relay, a bad connection or bad wiring has to be determined.

If you are handy, short the THERM connection at the A/C unit. That'll divide the problem in half.

If you are not handy, a trip to the dealer is in order.
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck

Sitting in The Cheap Seats.
And proud of it!
mike837go is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:26 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.