Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-20-2016, 12:33 PM   #1
fdhealy4's Avatar
Join Date: Mar 2016
Location: Golden
Posts: 57
5 amp CB

During our first trip with the new TT I had reason to take a closer look at the CB panel. Right below the A/C 20 amp CB is a 5 amp CB labeled "Utility". I couldn't find anything in the TT that seemed to run off it. Called Jayco and they didn't know either. Anybody know the answer?


Dale and Deb
2016 Jay Flight 27BHS TT
2002 Suburban 2500 8.1L
fdhealy4 is offline   Reply With Quote
Old 06-20-2016, 01:12 PM   #2
northwindone's Avatar
Join Date: Feb 2016
Location: California High Desert
Posts: 73
Could it be your utility converter, i.e. the battery charger/maintainer? Even at full output it wouldn't need anything near 15A so a 5A breaker would make sense.

2006 Jay Flight 29BHS
1999 F350, XLT, 4x4, 6.8L V10, AT, CC, LB
northwindone is offline   Reply With Quote
Old 06-20-2016, 02:26 PM   #3
Senior Member
hoppers4's Avatar
Join Date: Mar 2015
Location: Port Orchard
Posts: 790
Outside bay lights or outlets?
2015 Greyhawk 29MV
Honda CRV toad with Blue Ox baseplate
Ready Brute Elite towbar with braking system
Hughes autoformer
TST 507 Flowthru TPMS
hoppers4 is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:44 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.