Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-09-2010, 05:58 PM   #1
Join Date: Jan 2010
Posts: 35
Atwood water heater

Hi, I have a Atwood 6 gallon water heater model# G6A-7 with standing pilot.The last few times I have used it the pilot has gone out a couple of times. What can I do to fix this? How do you clean the tube or whatever. Any help would be appreciated. Thanks

George & Barbara
2012 Toyota Tundra dbl cab 4x4 5.7 V8
2006 Jayco Jay Feather Sport 186
gserve is offline   Reply With Quote
Old 07-16-2010, 03:16 PM   #2
Junior Member
Join Date: Jul 2010
Location: Red River Ranch Rv Resort Thackerville Ok.
Posts: 20
usually if the piolet wont stay lit the thermocuple is generally the culprit. my spelling isnt so good so im sure thats not spelled right but thats where id start. good luck

wannagetrdone is offline   Reply With Quote
Old 07-16-2010, 03:25 PM   #3
Senior Member
Join Date: Apr 2010
Posts: 213
Wannagetrdone's right, check the thermocouple. You might also take a look and see if you have one of the water heaters that will run on electrical power, many do. If you have this type (look where the on-off switch for the water is) use the electric heating element when connected to shore power (campground hookup) and save your propane.
RR Conductor is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:49 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.