Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-26-2016, 01:48 PM   #1
Junior Member
Join Date: Aug 2015
Location: Arvada
Posts: 28
Could my monitor panel be bad?

This morning the pump and the hot water heater do not work on my 2016 264bhw. I checked the fuses and they are fine. I get red lights on the panel but no pump and no hot water.

ArvdaJayco is offline   Reply With Quote
Old 05-26-2016, 02:03 PM   #2
Senior Member
oldmanAZ's Avatar
Join Date: Dec 2014
Location: AZ
Posts: 3,776
The pump and water heater need 12v. Are you boondocking? Have been using your furnace? Have you checked your battery state of charge? (The indicator lights may work even with a very low battery state of charge.)

Sherm & Terry w/rescues Steve (std Poodle) & Eydie (min Schnauzer)
2015 Jay Flight 27RLS (Camped: 102 nights 2015, 90 nights 2016)
2006 Ford F350 6.0 PSD, Lariat, 4WD, CC, LB, SRW, auto., Camper pkg.
oldmanAZ is offline   Reply With Quote
Old 05-26-2016, 02:08 PM   #3
Junior Member
Join Date: Aug 2015
Location: Arvada
Posts: 28
I am plugged into shore power. The furnace is working and so is the fridge.

The battery seems fine. Lights and furnace work when unplugged
ArvdaJayco is offline   Reply With Quote
Old 05-26-2016, 02:25 PM   #4
Senior Member
Grumpy's Avatar
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 3,522
Since they are probably close to each other could he a loose ground which they may share.
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 05-26-2016, 02:30 PM   #5
Senior Member
RVhiker's Avatar
Join Date: Dec 2010
Posts: 1,100
Is the problem with the propane hot water heating system or the 120 V electric system? If propane, do you have it turned on? Do you have a good flame at the stove? Does your furnace heater make heat, or are you just hearing its fan? If electric, have you allowed for the hour or so it might take for the electric side to heat up the water in the water heater? Your refrigerator works, but is it working on propane or 120V electric?

Can you hear your water pump running, and it is just not pumping water? Or is the water pump not making any noise at all?
There's lots of advice and information in forums... sometimes it is correct. For example, all of my posts are made by a political appointee who got the job as a reward for contributions to my diesel bill.

2011 Jayco 28.5RLS; 2008 Chevy Duramax; Pullrite Superglide Hitch

RVhiker is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.