Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-30-2014, 03:46 PM   #1
Senior Member
nunyadamn's Avatar
Join Date: Apr 2014
Location: Gilbert
Posts: 415
Dual white hoses - water lines - water level

Went camping this weekend with our new trailer - 2014 32BHDS. I was filling up the water tank and then started to see water coming from two white hoses. I was expecting when the water tank was full that water would come back out of the vent near the fill port - like my past RV. At first I thought it was a couple of drain ports that are under my sink - these water lines are red and blue. When I pulled those up, the water poured out really fast under pressure - I believe I had my water pump on. It took me a few minutes to figure out that the lines outside were not the same - kept thinking they were the same set of hoses. Then I finally found the red and blue lines under the trailer. after a few minutes the white lines stopped flowing and we went to our site.

So I guess my question is - are the while lines just vent lines or over flow lines?

Another question I have is - can the water level sensors be calibrated better?

I drove home from the mountains with the fresh water level at the last light (empty I thought). Went to dump the last travel grey/black tanks when I got home. While using the toilet flusher (foot pedal) to put a little water in the black tank so I could add a toilet tab to the tank, I completely filled the black tank again. So, on empty for the fresh, I still had enough to fill the black tank - 32.5 gallons.

One last rhetorical question - why would Jayco put a 80 gallon fresh water tank and only 32.5 gallon black and grey tanks?

nunyadamn is offline   Reply With Quote
Old 05-30-2014, 06:24 PM   #2
Join Date: Oct 2013
Posts: 37
The initial water drain you experienced out the white line is most likely the onboard tank overflow line. Its been my experience as well with Jayco as opposed to other manufactures that the flow exits out this overflow line before spitting out the vent line at the fill (probably the way it should be). This is normal; these are tank overflow lines. One should have a valve to use to manually drain the onboard tank, the other is the main overflow.

The red/blue lines you say that you "pulled up" sound like the low point drain valves that you would use during winterizing to drain the onboard system.

Cant say much about tank sensors other than onboard water should be mostly accurate; grey somewhat accurate; and black totally useless after a few uses. If your fresh registered empty and you were able to fill your black from it, that sensor is obviously incorrect.
dxrobertson is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:02 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.