Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-23-2016, 07:11 AM   #1
JDP
Junior Member
 
Join Date: Jun 2016
Location: Burlington
Posts: 18
Furnace issue 2015 27DSRL

I have a 2015 27 DSRL and turned on furnace for the first time. All I got was a click no fan no heat. Fuses are all OK. AC works fine. Am I missing something? Is furnace accessible? Doesn't seem to be a service panel.
__________________

JDP is offline   Reply With Quote
Old 09-23-2016, 08:18 AM   #2
Senior Member
 
WyEm's Avatar
 
Join Date: Dec 2015
Location: Beaverton, Oregon
Posts: 153
Check to see if the little 2 amp fuse inside the T-stat is blown. It's happened to me.
__________________

__________________
2016 Jayco Whitehawk 27DSRL
2010 Ford F-150 XLT Supercrew with Max Tow
WyEm is offline   Reply With Quote
Old 09-23-2016, 08:30 AM   #3
JDP
Junior Member
 
Join Date: Jun 2016
Location: Burlington
Posts: 18
Quote:
Originally Posted by WyEm View Post
Check to see if the little 2 amp fuse inside the T-stat is blown. It's happened to me.
Would that not affect AC as well?
JDP is offline   Reply With Quote
Old 09-23-2016, 08:42 AM   #4
Senior Member
 
WyEm's Avatar
 
Join Date: Dec 2015
Location: Beaverton, Oregon
Posts: 153
Yes. Nothing worked on mine when the fuse popped.
__________________
2016 Jayco Whitehawk 27DSRL
2010 Ford F-150 XLT Supercrew with Max Tow
WyEm is offline   Reply With Quote
Old 09-23-2016, 08:45 AM   #5
JDP
Junior Member
 
Join Date: Jun 2016
Location: Burlington
Posts: 18
AC is fine...
JDP is offline   Reply With Quote
Old 09-23-2016, 08:45 AM   #6
Senior Member
 
WyEm's Avatar
 
Join Date: Dec 2015
Location: Beaverton, Oregon
Posts: 153
another thing to check is making sure all the air is bled out of the propane lines by lighting a burner in the stove first. Just a thought.
__________________
2016 Jayco Whitehawk 27DSRL
2010 Ford F-150 XLT Supercrew with Max Tow
WyEm is offline   Reply With Quote
Old 09-23-2016, 08:47 AM   #7
Senior Member
 
Join Date: May 2015
Location: Charles Town
Posts: 151
This happened to me when my 23 RB was new. With about two hours of service the furnace motor quit and after much research on the service departments end they replaced the motor and no problems since. I wish you luck and hope you find a simple fix.
__________________
2014 Toyota TundraTRD double cab 4x4 tow package off road package 46 gallon fuel tank
2015 Jayco Jayflight 23rb elite thermal package solar equipped
Racinforthefinish is offline   Reply With Quote
Old 09-23-2016, 08:48 AM   #8
Senior Member
 
Join Date: Sep 2015
Location: Thunder Bay
Posts: 116
Quote:
Originally Posted by WyEm View Post
another thing to check is making sure all the air is bled out of the propane lines by lighting a burner in the stove first. Just a thought.


That's what I was thinking also


Sent from my iPhone using Tapatalk
Coldfusion is offline   Reply With Quote
Old 09-23-2016, 08:51 AM   #9
JDP
Junior Member
 
Join Date: Jun 2016
Location: Burlington
Posts: 18
Thanks guys. Lots of propane, 12VDC OK all fuses fine. Looks like the furnace is buried behind cabinetry..I guess it's trip to dealer..
JDP is offline   Reply With Quote
Old 09-23-2016, 11:58 AM   #10
PMC
Member
 
Join Date: Jul 2016
Location: Bloomington
Posts: 39
I know this is going to sound like I'm treating you like an idiot (not intended that way at all) but make sure you have the temp turned up to the point that it'll actually kick on.

If it's still not working it sounds like it's definitely need to be looked at. Also the fan set to auto still won't turn on would mean it's not right, that should come on no matter what.

Same year same trailer in my driveway and we love it, no issues with the furnace. Worst thing about it was the bed and bathroom faucet, both of which have been replaced with something worth using.
__________________

PMC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.