Jayco RV Owners Forum

Thread Tools Display Modes
Old 09-12-2012, 06:57 PM   #1
Senior Member
Join Date: May 2012
Location: Southern Ontario, Canada
Posts: 105
Furnace won't fire up on new TT.

Hello..I have a 2012 Jayco Eagle Light 298RLDS. Overall, very pleased with this trailer. Trailer is on a seasonal site, 150 miles away from the nearest Jayco dealer. I used the furnace in the spring and it fired up as needed. Went to use the furnace a couple weeks ago and it wouldn't light. Blower starts up and there are a few clicks. Can smell propane coming from unit when I'm outside. Fan shuts off after a bit. Was at the trailer this past weekend and tried the furnace again....it started up and produced heat. The next day no luck....furnace wouldn't fire up. Of course my dealer will cover the warranty charges if I have a technician come out from a different RV dealer....who is about 60 miles away. Travel fees won't be covered. Any suggestions as to what I might try?

LilBigfoot is offline   Reply With Quote
Old 09-12-2012, 07:14 PM   #2
Senior Member
Jayco 228's Avatar
Join Date: Apr 2012
Location: Edmonton, Alberta Canada
Posts: 267
Propane full? Stove lights? Might need to purge the lines a little
2012 Toyota 4-Runner SR5
2012 Jayco Jay Feather Ultra Lite 228

Jayco 228 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:19 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.