Jayco RV Owners Forum

Thread Tools Display Modes
Old 04-27-2014, 10:44 PM   #11
Join Date: Jan 2014
Location: Ninilchik, Alaska
Posts: 94
Mine, CO/Prop. detector, went off last fall after we got set up in the RV prk. Those are irritating SOB's for sure. Bought a new one and pitched the old one, a 2011 model, out. No more problem.

Just beat it to death with $$$$$. Works most of the time and makes life much more pleasant..

2012 JAYCO BUNGALOW Jayflight 40FER
2004.5 Dodge Ram; CTD; 3500 Dually; CC; 4x4; 6 spd. 5600; Smarty Jr.
Jack in Alaska is offline   Reply With Quote
Old 04-28-2014, 11:18 PM   #12
Senior Member
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,263
Our alarm has gone off several times and each time I have found a knob on a burner not quite in the off position. Sallie now checks the knobs when she wipes down the range.

2011 Eagle 330RLTS with just about every option.
Dodge SRW 1 ton Cummins powered.

I was born with nothing and I still have most of it left.
clutch is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:17 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.