Jayco RV Owners Forum

Thread Tools Display Modes
Old 10-09-2012, 09:28 AM   #1
Junior Member
Join Date: Jun 2012
Location: E.Mass
Posts: 26
More nagging problems

We took the trailer out for the last time this past weekend. All set up, I went back into the closet to grab a jacket and noticed a puddle of water on the floor. From the area of the sliding door that covers the plumbing for the bathtub. After taking care of the puddle, saw that the hot and cold water pipes(tubing), and the surrounding area had droplets all over. Something had sprayed. Initially couldn't find anything wrong, but found that the hot water connection, tubing to bath tub faucet was dripping. At the threads.

I didn't have any teflon tape with me, so I just let it drip into a bowl. I didn't want to take the joint apart to find crossed or stripped threads, and not be able to fix it.

Going back to dealer for some different repairs, this one will be on the list.

# 2... Attempting to watch a movie, the TV wouldn't play. It did a while ago, but not now. I had the blue screen and menu box up for 5 sec. or so than all black. Need to call customer service to see what to do. I think the A/V stuff is through the mfg, not Jayco.

Nothing catastrophic, just a pain in the rear.
Bob in Mass is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:10 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.