Jayco RV Owners Forum

Thread Tools Display Modes
Old 10-26-2012, 05:11 AM   #1
Join Date: Sep 2012
Location: Central Florida
Posts: 35
Norcold Refrigerator in 2003 Jayco

Does anyone have any problem with the Norcold Refrig? When ours is set in the Auto position, it may run for the day, or maybe the night, then it will switch to a "S" in the display? The dealership told my husband to go to the outside and unplug (something), lol and it would reset itself...This worked for one day. The dealership came and put a new board(?) in and the next morning it was back on "S". Has anyone had this problem or maybe knows what it means? Guess I need to call Norcold, huh?

Bonieta Joyce is offline   Reply With Quote
Old 10-26-2012, 08:45 AM   #2
Senior Member
Terry's Avatar
Join Date: Feb 2011
Location: Germantown, TN
Posts: 4,923
I believe an "S" error code is a bad flame sensor. The recommended fix from Norcold is to replace the power board - which sounds like what they did.

What model fridge do you have? There are service manuals out there that may help you diagnose your problem a little better.
2009 Jayco 26BH
2004 Chevy Silverado 1500
2009 JayFlight Manual Library

Want to add a signature to your posts? --> Click Here
Terry is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.