Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-31-2015, 07:36 PM   #1
Junior Member
Join Date: Apr 2015
Location: Okanagan
Posts: 8
Usb ports

Hi I have some usb ports not working as well as my gfci plugs are these wired to gather my fuses seem to look ok on my 23 rb traler everything else is working any ideas thanks

Trailerboy66 is offline   Reply With Quote
Old 08-31-2015, 10:17 PM   #2
Senior Member
Jagiven's Avatar
Join Date: May 2012
Location: Minnesota
Posts: 3,185
Good chance they are. What year tt? However they could be running off 12 volt too.

Have you tried to reset the GFI yet. It should be in the bathroom. On most trailers, all the outlets except for the microwave are all on one circuit.

Jagiven is offline   Reply With Quote
Old 08-31-2015, 10:32 PM   #3
Junior Member
Join Date: Aug 2015
Location: Amherst
Posts: 25
the usb is on 12v has its own fuse but have found it is usually the plug itself simple fix tho. detach the fixture from the wall and check voltage on the wires behind it if they are good disconnect and redo the connection to the outlet. takes all of 5 minutes and cost is 0.00 thats a pleasant change
chuckerg is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:47 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.