Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-11-2016, 08:47 AM   #1
Junior Member
Join Date: May 2016
Location: milton
Posts: 1
x213 slide issues

I have a 2012 jay feather x213, my rear slide stops aprox. 8 inches before it is fully extended.. if I lift up on the slide while my wife extends it, it does extend fully.
Side to side it is even.
I have it plugged in to 120v shore power.
The trailer is level.

I have called jayco customer service but they weren't any help...
Has anyone had a similar issue?
Or any advice...

supermario27 is offline   Reply With Quote
Old 05-15-2016, 08:00 AM   #2
Junior Member
Join Date: Mar 2011
Location: Whitby
Posts: 2
Welcome to the X213 Rear Slide Problem.

There have been several posts on this issue. Just Search on X213.
Two things you need to do. First check that your drive motor has been replaced with the latest version. The motor on the 2012 should be the same as the 2016 if it has been replaced. You are out of Warranty now, but if it was replaced, it was probably done under warranty.
Secondly, the rubber surround on the slide out hardens over time and puts more pressure on the motor. Some rubber treatment (silicone) will keep it softer, and the slide should work fine.
Good luck.
dukercan is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:07 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.