Jayco RV Owners Forum

Thread Tools Display Modes
Old 09-06-2014, 11:57 AM   #1
Junior Member
Join Date: Sep 2014
Location: Quinlan
Posts: 1
Exclamation Cable trouble, please help!

I have a 93 j series and when I was cranking it up I heard a noise. Anyway I believe nothing broke, that it just came undone. But I'm new to the pop up world. Amy help would be greatly appreciated!
Attached Thumbnails
20140906_115656.jpg   20140906_115707.jpg   20140906_115718.jpg  

jmaynor08 is offline   Reply With Quote
Old 09-08-2014, 09:32 AM   #2
Join Date: Mar 2014
Location: pinson Alabama
Posts: 44
cable repair.....

I refurbished a 94 1006 recently and used it on an 8 day road trip in July. The lift started to stiffen up as I used it and the last day, while lowering the top, the tube that the crank fits into broke off the winch.

I took it apart and it looked like the cable had gotten bound up on the winch drum. After having the handle tube welded back I un-wound the cable completely, cleaned and lubed it and wound it back onto the drum. The tricky part was reinstalling the winch while keeping the cable tight. Vice grips worked for that, until I could get the lift cables reattached.
Now it works smoother then ever ..... The key, I think, is to not allow the winch cable to go slack when lowering the top. Give it a half crank tight once the top is secured down.
rockerarm is offline   Reply With Quote

cable repair

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:20 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.