Jayco RV Owners Forum

Thread Tools Display Modes
Old 08-25-2013, 12:07 PM   #21
Join Date: Jul 2011
Posts: 81
Three years ago I forgot to unhook the emergency break-away brake lanyard on our model 2010 Jayco 1007 popup and pulled it out when uncoupling. The dealer supposedly reset it, but ever since then the surge brakes on the trailer have hopped like mad. I have to brake either gently or very hard to avoid the hopping, there's no in-between. The dealer has tried four -- FOUR!! -- times to fix it with no luck. They've adjusted the brakes, diagnosed a contaminated brake shoe and replaced it, and nothing works. I am convinced they simply never reset the emergency actuator properly, because it sticks out of its socket oddly and the lanyard is shorter than it used to be (they had to add a large carabiner to make it long enough to hook up to the drawbar again). It's like the brakes are warped or still partially engaged or something. Anyone have any hints on how to reset an Atwood emergency actuator properly?
BTW I will never have mickey mouse surge brakes again, electric brakes have got to be far better.

Rapidly is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:45 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.