Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-02-2013, 04:17 PM   #1
Junior Member
Moose73's Avatar
Join Date: May 2013
Location: Arlington Height, IL
Posts: 16
Trailer Lights - Running, Turning, Brake

I had an issue with my trailer lights - as apposed to the camper lights. I found a simple solution and wanted to share it because I couldn't find the answer in the forum search. I also would like to know if anyone has replaced those lights with LED's.

So my issue... When plugged in to my tow vehicle for the first time this year I was able to get the running (parking) lights to work but not the brake or turn signals. By the time I made it home from the storage yard I had brake and turn lights but no running lights. I thought this was odd so I started testing the harness with a volt meter - just for pass through, no load. Everything worked fine so I decided that I should check the fuses and found the 15 amp running light fuse was blown. When I replaced that fuse the running lights came back on and the brake and parking lights stopped working again. At this point I was a bit confused and test with and without the fuse a few times before deciding I needed some help and started researching the inter-web (or as my father-in-law use to say, checking on some W-W-W's). I found a site that lead me to start checking the ground connection and to finish a long short quickly...I found that the bulbs in the tail lights had a film on them causing them not to ground correctly. I sprayed them down with some carb-cleaner (Goo-Gone would have worked too) and made sure they were clean and dry before putting them back. To my surprise that did it!!! The dirt brass on the bulbs caused a bad ground in the system and wouldn't let both the running and the braking lights work at the same time! Incredible!
--- So I added a few unneeded word in there just to make sure that if someone searched using the same keywords I used they would find this - it's so simple that even someone with basic knowledge of electrical can do this - if you can change the bulb you may be able to fix the issue ---

On to my QUESTION... I want to replace the old bulbs with LED's for brightness and durability. Anyone have any suggestions on this.

2000 Jayco Eagle 14SO
Moose73 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:56 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.