RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-23-2020, 09:01 AM   #1
Senior Member
 
Join Date: May 2016
Location: Milpitas
Posts: 1,125
Charcoal from water filter?

We have started noticing a spurt of black water when we turn on our faucet after hooking up. I flushed the system and purchased new filters (Camco in line blue filters). This morning after a freeze I run the hose to clear the air before I hooked up and a black spurt came right out of the filter. Anyone else see this?
__________________
2019 Chevy express 2500 Van Coversion. 2017 Jayco 23MRB: 26' total and Glacier Package. 2 Renogy solar panels. Married 46 years. Aki the "mutt," 14 years old "Excited to learn new things everyday and humbled by those who offer to help."
travelingjw is offline   Reply With Quote
Old 10-23-2020, 10:00 AM   #2
CAG
Senior Member
 
CAG's Avatar
 
Join Date: Oct 2019
Location: Phoenix
Posts: 1,309
By flushing the system, do you mean you sanitized? Black algae in the hot water tank or other locations in the system for that matter? Have you left water sitting in the tank? Also, even though you drain water supply tanks, there is always a small amount of water left. It grows bad things between uses.


I accidentally left water in the tank between uses. What came out was about 6 gals of black, and I do mean black water. Water left sitting, especially in our temps here, goes bad pretty fast.
__________________
2018 Jayco Greyhawk 29MVP
2019 Jeep Sahara Unlimited
2011 Cyclone 3010 Toy Hauler- Sold
2014 Chevy Silverado Duramax LML -Sold
CAG is offline   Reply With Quote
Old 10-23-2020, 10:30 AM   #3
Senior Member
 
Join Date: May 2016
Location: Milpitas
Posts: 1,125
I didn't sanitize, I just ran water through every faucet to assure that any "matter" would be flushed out. The black spurt only comes out of the sink nearest to the city water inlet. When we get home I am going to disconnect the P-trap and check the low point. But the fact that I had a black spurt prior to hooking up this morning makes me suspicious that it is charcoal from the filter. This is also because the color is dark black, not "mold" black.
__________________
2019 Chevy express 2500 Van Coversion. 2017 Jayco 23MRB: 26' total and Glacier Package. 2 Renogy solar panels. Married 46 years. Aki the "mutt," 14 years old "Excited to learn new things everyday and humbled by those who offer to help."
travelingjw is offline   Reply With Quote
Old 10-23-2020, 10:34 AM   #4
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 6,794
Quote:
Originally Posted by travelingjw View Post
We have started noticing a spurt of black water when we turn on our faucet after hooking up. I flushed the system and purchased new filters (Camco in line blue filters). This morning after a freeze I run the hose to clear the air before I hooked up and a black spurt came right out of the filter. Anyone else see this?
How new is the filter? Is the filter located at the CG hose bib? Are you using one of the Blue RV filters or do you have a whole house filter with independent filter cartridge. Did you shake it to get all the water out when you drained it?

My experience with whole hose filters, it is not uncommon to get charcoal fines out of them when I first add water.
Jagiven is offline   Reply With Quote
Old 10-23-2020, 10:54 AM   #5
Senior Member
 
Join Date: May 2016
Location: Milpitas
Posts: 1,125
Thanks, the filter is brand new. I place the filter right at the inlet to the TT. It is a Camco blue filter which we have used since we since we purchased the TT. I purchase 2 and swap them out in the middle of our traveling season.
__________________
2019 Chevy express 2500 Van Coversion. 2017 Jayco 23MRB: 26' total and Glacier Package. 2 Renogy solar panels. Married 46 years. Aki the "mutt," 14 years old "Excited to learn new things everyday and humbled by those who offer to help."
travelingjw is offline   Reply With Quote
Old 10-23-2020, 11:13 AM   #6
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 6,794
My experience I always get charcoal dust out of a new filter. My home filter cartridges instructions, state to run the closest faucet for a minimum of 5 or 10 minutes to flush out the charcoal dust.
Jagiven is offline   Reply With Quote
Old 10-23-2020, 01:34 PM   #7
Lost in the Woods
 
Join Date: Apr 2019
Location: Ocean County
Posts: 2,807
I get that black spurt EVERY time I hook up my Camco filter, even when it's been used before.

It's a burst of charcoal from the filter.

So, before I hook up my hose to the rig, I first blast out the hose bid and let it clear. I've had dirty water come out the hose bib when first turned on. Then, I hook up my pressure reducer, blue filter, and water line, and turn the bib back on to flush the hose and filter. I ALWAYS see a black spurt come out, even after multiple uses.

Once I let it run clean for a minute or two, I turn off the hose bib and attach to the rig.
RetiredOne is offline   Reply With Quote
Old 10-23-2020, 10:14 PM   #8
Site Team
 
JFlightRisk's Avatar
 
Join Date: Apr 2012
Location: Newark, NY
Posts: 7,520
Quote:
Originally Posted by travelingjw View Post
We have started noticing a spurt of black water when we turn on our faucet after hooking up. I flushed the system and purchased new filters (Camco in line blue filters). This morning after a freeze I run the hose to clear the air before I hooked up and a black spurt came right out of the filter. Anyone else see this?
I did the same thing the first time I hooked up a new filter to our TT. I didn't flush it first, and the charcoal dust went through our plumbing. It got into the water heater, which didn't impress the DW when she went to take a shower. It looks bad, but is harmless. Just another learning experience in the world of RVs.
__________________
Every day's a learning experience, though sometimes not what we expected.

2012 Jay Flight 19RD
2016 Ford F150 XLT 2X4 SC 3.5L Eco Max Tow
2010 Tundra TRD DBL Cab (Traded)
1 Spoiled Dog
JFlightRisk is offline   Reply With Quote
Reply

Tags
black water, water filters

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 02:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.