Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 05-22-2018, 09:26 PM   #1
Junior Member
 
Join Date: Apr 2018
Location: Dayton
Posts: 24
Generator

Hello I have a 2013 Jayco Melbourne 28f. I had the generator on and was using theA/C and the microwave at the same time. Then they both shut off after about 3 mins. I thought the breaker blew, but the breaker looks fine. But now neither will work with the generator on. I confirmed they do work plugged into shore. I will be departing on a trip and will need to use the Items, separately with just the generator. Please help me. I thank you
__________________

Gmward69 is offline   Reply With Quote
Old 05-22-2018, 09:41 PM   #2
Senior Member
 
cabinetmaker's Avatar
 
Join Date: Mar 2018
Location: Granbury
Posts: 750
Your Melbourne may be like our Greyhawk and since it only has 30 amp service uses a power manager to shed amps when power becomes overloaded.

If you have one of those I would take a look there.

Funny thing is you said all works ok on shore power...maybe the breaker tripped on the generator. It is located on the genset kind of hidden on the side. I would check that first.
__________________

__________________
2018 Greyhawk 29MVP
2018 Jeep 4 Door Rubicon Recon
Retired and Under New Management (See Spouse For Details)
cabinetmaker is offline   Reply With Quote
Old 05-23-2018, 02:18 PM   #3
Senior Member
 
2edgesword's Avatar
 
Join Date: Jul 2011
Location: Long Island, NY
Posts: 698
If they're both working on shore power then it's probably as cabinetmaker said, the generator overload protection needs to be reset.
__________________

2018 Jayco 28RLS
2012 F-250 6.2L 3.73
Equalizer Hitch
Yamaha 2400ISHC
2edgesword is offline   Reply With Quote
Old 05-23-2018, 03:05 PM   #4
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 6,472
Your geny may only have a 20/25 amp breaker and as was mentioned it probably tripped.
__________________
DISNEY LOVERS
Grumpy is offline   Reply With Quote
Old 05-23-2018, 05:16 PM   #5
Junior Member
 
Join Date: Apr 2018
Location: Dayton
Posts: 24
Thank you so very much it was the breaker on the generator. We never even knew there was a breaker on the generator, this was a very good mistake to make in case it ever happens again in the future.
Gmward69 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 04:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.